aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-01-08 23:01:06 +0100
committerJan200101 <sentrycraft123@gmail.com>2022-01-08 23:01:06 +0100
commit29acda971adc34e2085d8d3749aff3d898144a70 (patch)
treeba71b079397a8de8c8fa60ffbcc1513263c05d33 /CMakeLists.txt
downloadsameboy-thumbnailer-29acda971adc34e2085d8d3749aff3d898144a70.tar.gz
sameboy-thumbnailer-29acda971adc34e2085d8d3749aff3d898144a70.zip
initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..b27aaf4
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 3.18)
+
+if(CMAKE_POLICY_DEFAULT_CMP0017 OR CMAKE_POLICY_DEFAULT_CMP0020)
+ # touch these to remove warnings
+endif()
+
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE "Release" CACHE STRING
+ "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel." FORCE)
+endif()
+
+project(sameboy-thumbnailer VERSION 0.0.0 LANGUAGES C)
+
+add_compile_definitions(VERSION=${CMAKE_PROJECT_VERSION})
+
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+
+add_subdirectory(src) \ No newline at end of file