aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2020-10-11 18:17:01 +0200
committerJan200101 <sentrycraft123@gmail.com>2020-10-11 18:17:01 +0200
commit7d4e2f33a619b1f46a8f2ba00afa22edca6579e8 (patch)
treec4af21c3d2c727929d9489b3c931cc4b64898bf2 /meson.build
parent26b0417ced82ad849e08db8e8aed0d5529c2b433 (diff)
downloadpolecat-7d4e2f33a619b1f46a8f2ba00afa22edca6579e8.tar.gz
polecat-7d4e2f33a619b1f46a8f2ba00afa22edca6579e8.zip
replace meson with cmake
meson is nice but its completly foreign to me and leaves targets to compile to (e.g Makefile) might revisit in the future but now right now
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build39
1 files changed, 0 insertions, 39 deletions
diff --git a/meson.build b/meson.build
deleted file mode 100644
index c4d1bff..0000000
--- a/meson.build
+++ /dev/null
@@ -1,39 +0,0 @@
-project(
- 'polecat',
- 'c',
- default_options : [
- 'buildtype=debugoptimized',
- ],
- license : 'MIT',
- version : '0.1.5',
-)
-
-libarchive_dep = dependency('libarchive')
-libcurl_dep = dependency('libcurl')
-libjson_c_dep = dependency('json-c')
-
-conf_data = configuration_data()
-conf_data.set_quoted('NAME', meson.project_name())
-conf_data.set_quoted('VERSION', meson.project_version())
-if get_option('release')
- conf_data.set('NDEBUG', true)
-else
- conf_data.set('DEBUG', true)
-endif
-configure_file(output : 'polecat-config.h', configuration : conf_data)
-
-conf_inc = include_directories('.')
-
-run_target(
- 'loc',
- command : [
- 'sh',
- '-c',
- 'find src'
- + ' -type f'
- + ' -name "*.cpp" -o -name "*.c" -o -name "*.h" -o -name "*.hpp"'
- + ' | xargs wc -l',
- ],
-)
-
-subdir('src')