aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 14 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e7f9138..9625d01 100644
--- a/meson.build
+++ b/meson.build
@@ -58,4 +58,17 @@ if get_option('static')
cflags += '-DLPM_STATIC'
endif
-executable('lpm', lpm_source, dependencies: [zlib_dep, lzma_dep, mbedtls_dep, libgit2_dep, libzip_dep, lua_dep, microtar_dep], c_args: cflags)
+lpm_exe = executable('lpm',
+ lpm_source,
+ dependencies: [
+ zlib_dep,
+ lzma_dep,
+ mbedtls_dep,
+ libgit2_dep,
+ libzip_dep,
+ lua_dep,
+ microtar_dep
+ ],
+ c_args: cflags,
+ install: true,
+)