aboutsummaryrefslogtreecommitdiff
path: root/lib/mbedtls-2.27.0/programs/test/cmake_subproject/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Harrison <adamdharrison@gmail.com>2023-07-06 06:37:41 -0400
committerAdam Harrison <adamdharrison@gmail.com>2023-07-06 06:37:41 -0400
commit9db10386430479067795bec66bb26343ff176ded (patch)
tree5ad0cf95abde7cf03afaf8f70af8549d46b09a46 /lib/mbedtls-2.27.0/programs/test/cmake_subproject/CMakeLists.txt
parent57092d80cb07fa1a84873769fa92165426196054 (diff)
downloadlite-xl-plugin-manager-9db10386430479067795bec66bb26343ff176ded.tar.gz
lite-xl-plugin-manager-9db10386430479067795bec66bb26343ff176ded.zip
Removed old mbedtls, replacing with submodule.
Diffstat (limited to 'lib/mbedtls-2.27.0/programs/test/cmake_subproject/CMakeLists.txt')
-rw-r--r--lib/mbedtls-2.27.0/programs/test/cmake_subproject/CMakeLists.txt23
1 files changed, 0 insertions, 23 deletions
diff --git a/lib/mbedtls-2.27.0/programs/test/cmake_subproject/CMakeLists.txt b/lib/mbedtls-2.27.0/programs/test/cmake_subproject/CMakeLists.txt
deleted file mode 100644
index a9fcfde..0000000
--- a/lib/mbedtls-2.27.0/programs/test/cmake_subproject/CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
-cmake_minimum_required(VERSION 2.6)
-
-# Test the target renaming support by adding a prefix to the targets built
-set(MBEDTLS_TARGET_PREFIX subproject_test_)
-
-# We use the parent Mbed TLS directory as the MBEDTLS_DIR for this test. Other
-# projects that use Mbed TLS as a subproject are likely to add by their own
-# relative paths.
-set(MBEDTLS_DIR ../../../)
-
-# Add Mbed TLS as a subdirectory.
-add_subdirectory(${MBEDTLS_DIR} build)
-
-# Link against all the Mbed TLS libraries. Verifies that the targets have been
-# created using the specified prefix
-set(libs
- subproject_test_mbedcrypto
- subproject_test_mbedx509
- subproject_test_mbedtls
-)
-
-add_executable(cmake_subproject cmake_subproject.c)
-target_link_libraries(cmake_subproject ${libs})