aboutsummaryrefslogtreecommitdiff
path: root/src/local/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/local/CMakeLists.txt')
-rw-r--r--src/local/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/local/CMakeLists.txt b/src/local/CMakeLists.txt
new file mode 100644
index 0000000..8e35f2b
--- /dev/null
+++ b/src/local/CMakeLists.txt
@@ -0,0 +1,16 @@
+
+find_package(spdlog REQUIRED)
+find_package(NorthstarPluginABI REQUIRED)
+
+add_executable(LocalRPC
+ $<TARGET_OBJECTS:SouthRPC>
+ "${CMAKE_CURRENT_SOURCE_DIR}/main.cpp"
+)
+target_include_directories(LocalRPC PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/..")
+target_link_libraries(LocalRPC rapidjson_header)
+target_link_libraries(LocalRPC ws2_32)
+target_precompile_headers(LocalRPC PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/../ns_plugin.h")
+
+target_link_libraries(LocalRPC spdlog::spdlog_header_only)
+target_include_directories(LocalRPC PRIVATE ${NS_DLL_DIR})
+target_include_directories(LocalRPC PRIVATE ${NS_PLUG_DIR}) \ No newline at end of file