aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2019-09-22 12:39:05 +0200
committerJan200101 <sentrycraft123@gmail.com>2019-09-22 12:39:05 +0200
commitb627cce56bc49bea458ef89f2c836d197a67166d (patch)
tree6f1193b4e21a91b07d533da181c840073b706d70 /setup.py
downloadShellyPy-b627cce56bc49bea458ef89f2c836d197a67166d.tar.gz
ShellyPy-b627cce56bc49bea458ef89f2c836d197a67166d.zip
Initial Commit0.1.0
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..f62ed46
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,37 @@
+import setuptools
+import re
+
+requirements = []
+with open('requirements.txt') as f:
+ requirements = f.read().splitlines()
+
+version = ''
+with open('ShellyPy/__init__.py') as f:
+ version = re.search(r'^__version__\s*=\s*[\'"]([^\'"]*)[\'"]', f.read(), re.MULTILINE).group(1)
+
+if not version:
+ raise RuntimeError('version is not set')
+
+long_description = ""
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+
+setuptools.setup(
+ name="ShellyPy",
+ version=version,
+ author="Jan Drögehoff",
+ description="Wrapper around the Shelly HTTP api",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://github.com/Jan200101/ShellyPy",
+ packages=["ShellyPy"],
+ license="MIT",
+ install_requires=requirements,
+ classifiers=[
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ ],
+) \ No newline at end of file