aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-07-22 21:08:09 +0200
committerJan200101 <sentrycraft123@gmail.com>2022-07-22 21:57:39 +0200
commit1de8b89807222b5673505fea2bec1af4c0af8c7d (patch)
treef0b7a5e08013114a5b3f927d93caa8f674775fa9 /src/CMakeLists.txt
parente4cff606fccdb7b8ac1c9bf5204a6b52e296bfe9 (diff)
downloadOFQT-1de8b89807222b5673505fea2bec1af4c0af8c7d.tar.gz
OFQT-1de8b89807222b5673505fea2bec1af4c0af8c7d.zip
Correct function prototypes,add more Cflags for sanity,add sanity assets
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ffc77c7..af7cbe3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,6 +6,9 @@ add_subdirectory(vdf)
set(CFLAGS
-Wall -Wextra -pedantic
+ -Wfloat-equal -Wundef
+ -Wstrict-overflow=5 -Wunreachable-code
+ -Wcast-qual -Wswitch-default
-Wconversion -Wshadow -Wstrict-aliasing
-Winit-self -Wcast-align -Wpointer-arith
-Wmissing-declarations -Wmissing-include-dirs