aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeckoEidechse <40122905+GeckoEidechse@users.noreply.github.com>2024-11-20 21:34:21 +0100
committerGitHub <noreply@github.com>2024-11-20 21:34:21 +0100
commitb9ecae0389d09be94eb3b53a98ddcaab9b74e702 (patch)
tree9648d03f52fdfbcef7a219afa8df88247cee3da6 /CMakeLists.txt
parent04b7527fb0bdfce61d39c9d7de57f8c1e21ae660 (diff)
parent3e40fa3c9a589b7fc5088c43ead2b32bf68c6bbe (diff)
downloadNorthstarLauncher-b9ecae0389d09be94eb3b53a98ddcaab9b74e702.tar.gz
NorthstarLauncher-b9ecae0389d09be94eb3b53a98ddcaab9b74e702.zip
Merge branch 'main' into feat/whitelist-safeio-file-extensions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9646ae1..c9516e52 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,3 +50,7 @@ include_directories(primedev/thirdparty)
# Targets
add_subdirectory(primedev)
+# Forces Minizip to not use functions that are not available in Win 7 libraries.
+if(WIN32)
+ target_compile_definitions(minizip PUBLIC -D_WIN32_WINNT=0x0601)
+endif()