aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorF1F7Y <64418963+F1F7Y@users.noreply.github.com>2023-06-22 11:47:46 +0200
committerGitHub <noreply@github.com>2023-06-22 11:47:46 +0200
commit89996405ee6341252836d606d5de02fff83ec3ab (patch)
treed8e70b4f8a1a2d125e4693806799477f6a46bfe7 /CMakeLists.txt
parent9cf27a61fd7e096f816c512375ef2340ea4dfb10 (diff)
downloadNorthstarLauncher-89996405ee6341252836d606d5de02fff83ec3ab.tar.gz
NorthstarLauncher-89996405ee6341252836d606d5de02fff83ec3ab.zip
Move to cmake (#467)v1.15.0-rc1
Moves the entire project to cmake as the build system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..18030b4a
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 3.15)
+
+project(Northstar CXX ASM_MASM)
+
+# Language specs
+set(CMAKE_CXX_STANDARD 20)
+set(CMAKE_C_STANDARD 17)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+set(CMAKE_VS_PLATFORM_TOOLSET v143)
+
+# This determines the real binary root directory
+set(NS_BINARY_DIR ${CMAKE_BINARY_DIR}/game)
+# NOTE [Fifty]: Visual studio deems Build root with the value "${projectDir}"
+# in CMakeSettings.json as invalid and defaults to using a temporary dir
+# somewhere in %USER%/CMakeBuilds. To combat this we set it to "${projectDir}/build"
+# and then link binaries in ${CMAKE_BINARY_DIR}/game. This means you can copy your
+# game into ${CMAKE_BINARY_DIR}/game without it being cluttered up by cmake files.
+
+message("NS: Building to ${NS_BINARY_DIR}")
+
+# Targets
+add_subdirectory(loader_wsock32_proxy)
+add_subdirectory(NorthstarDLL)
+add_subdirectory(NorthstarLauncher)