aboutsummaryrefslogtreecommitdiff
path: root/primedev/CMakeLists.txt
diff options
context:
space:
mode:
authorJan <sentrycraft123@gmail.com>2024-02-18 22:11:09 +0100
committerGitHub <noreply@github.com>2024-02-18 22:11:09 +0100
commit30e58ac08b6ee122de3130f3f02d6a855130ae51 (patch)
tree9f7abd79db5af2191ea7df1b9046c4378182e092 /primedev/CMakeLists.txt
parentfc63948e092b3495461e7aab4748af27c6dfa5ee (diff)
downloadNorthstarLauncher-30e58ac08b6ee122de3130f3f02d6a855130ae51.tar.gz
NorthstarLauncher-30e58ac08b6ee122de3130f3f02d6a855130ae51.zip
Clean up wsock proxy code and move wsock build system logic (#671)v1.24.1-rc2v1.24.1-rc1v1.24.1
- moves `WSockProxy` to `wsockproxy/CmakeLists` - remove exepath stuff from dllmain + its still done in loader.cpp because its used when reporting failure - Disabled any Thread Library calls + we don't need to know about threads at all in the proxy - yoink `wsock32.asm` into outer space + turns out, we can just call the function in a void shim since that wont touch the registers - stop copying `wsock32.dll` to the game directory + this should improve the state of things when using the EA App
Diffstat (limited to 'primedev/CMakeLists.txt')
-rw-r--r--primedev/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/primedev/CMakeLists.txt b/primedev/CMakeLists.txt
index 03f2628e..31dda4b2 100644
--- a/primedev/CMakeLists.txt
+++ b/primedev/CMakeLists.txt
@@ -1,3 +1,3 @@
include(Northstar.cmake)
include(Launcher.cmake)
-include(WSockProxy.cmake)
+add_subdirectory(wsockproxy)