aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan <sentrycraft123@gmail.com>2023-07-22 02:22:26 +0200
committerGitHub <noreply@github.com>2023-07-22 02:22:26 +0200
commitd3fb76f889101f024f410c194a66f0f4a2f6c4a0 (patch)
tree9739770458ee74e28474949b8e5e310c20f4734a /CMakeLists.txt
parent9841d698f89e1ec6cc9b0c04df10bad6010a54fe (diff)
downloadNorthstarLauncher-d3fb76f889101f024f410c194a66f0f4a2f6c4a0.tar.gz
NorthstarLauncher-d3fb76f889101f024f410c194a66f0f4a2f6c4a0.zip
Replace vendored libcurl and minhook with submodules (#500)v1.17.1-rc1
* Replace vendored libcurl and minhook with submodules * Add cmake utility for checking submodules and initializing them * Update build instructions to use Git
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4721a124..83c38a56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,9 @@ set(NS_BINARY_DIR ${CMAKE_BINARY_DIR}/game)
message(STATUS "NS: Building to ${NS_BINARY_DIR}")
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+include(utils)
+
# Targets
add_subdirectory(loader_wsock32_proxy)
add_subdirectory(NorthstarDLL)