aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <gecko.eidechse+git@pm.me>2024-12-23 00:43:17 +0100
committerGeckoEidechse <gecko.eidechse+git@pm.me>2024-12-23 00:43:17 +0100
commitbd52d5cddcc7986ee7c4ec4a7895d6df68617dae (patch)
tree25898f0b084e0eb701dd674fe3fa9bb32bfc5a2c /src-tauri/Cargo.toml
parent68eae7b348537ee09a19dfba21b88a3683a3b855 (diff)
downloadFlightCore-bd52d5cddcc7986ee7c4ec4a7895d6df68617dae.tar.gz
FlightCore-bd52d5cddcc7986ee7c4ec4a7895d6df68617dae.zip
build: Keep debug symbols in release code
for sentry.io
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index 56e42487..cf5f6bf9 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -9,6 +9,12 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[profile.release]
+# Keeps line tables in built binary
+# c.f.: https://doc.rust-lang.org/cargo/reference/profiles.html#debug
+# This is done to see line numbers in stack trace on sentry.io
+debug = 1
+
[lib]
# The `_lib` suffix may seem redundant but it is necessary
# to make the lib name unique and wouldn't conflict with the bin name.