aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-02-27 17:04:11 +0100
committerJan200101 <sentrycraft123@gmail.com>2022-02-27 17:04:11 +0100
commit346f8781f25255a35e708b22aea7e582853422bb (patch)
treedd1012d40a444c1733a89a5b1c4870e2e2c1edf4 /CMakeLists.txt
download3ds-splash-346f8781f25255a35e708b22aea7e582853422bb.tar.gz
3ds-splash-346f8781f25255a35e708b22aea7e582853422bb.zip
baseline
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3ba38ad
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 3.18)
+
+if(CMAKE_POLICY_DEFAULT_CMP0017 OR CMAKE_POLICY_DEFAULT_CMP0020)
+ # touch these to remove warnings
+endif()
+
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE "Release" CACHE STRING
+ "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel." FORCE)
+endif()
+
+project(splash VERSION 0.0.0 LANGUAGES C)
+
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+
+add_compile_definitions(VERSION=${CMAKE_PROJECT_VERSION})
+
+add_subdirectory(src) \ No newline at end of file