aboutsummaryrefslogtreecommitdiff
path: root/src/mock/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2021-05-27 23:37:23 +0200
committerJan200101 <sentrycraft123@gmail.com>2021-05-27 23:37:23 +0200
commitdf1df2929646abd77955b80e3ded3574ac005179 (patch)
tree9704901455843d41180a9402ed4c0012a1d67f04 /src/mock/CMakeLists.txt
parent68c20667ca775a4d4a7d1cfc3c9ec5c30f275084 (diff)
downloadpolecat-df1df2929646abd77955b80e3ded3574ac005179.tar.gz
polecat-df1df2929646abd77955b80e3ded3574ac005179.zip
allow flags to exit prematurely, move defines, add no networking flag
Diffstat (limited to 'src/mock/CMakeLists.txt')
-rw-r--r--src/mock/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/mock/CMakeLists.txt b/src/mock/CMakeLists.txt
index c2634d5..8b48c04 100644
--- a/src/mock/CMakeLists.txt
+++ b/src/mock/CMakeLists.txt
@@ -1,8 +1,9 @@
SET(CURL_SOURCES
- ${CMAKE_CURRENT_SOURCE_DIR}/libcurl/libcurl.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/libcurl.c
)
add_library(mockcurl STATIC ${CURL_SOURCES})
+target_compile_options(mockcurl PUBLIC ${CFLAGS})
target_include_directories(mockcurl PUBLIC ${LIBCURL_INCLUDE_DIRS})
set(NAME ${CMAKE_PROJECT_NAME}_mock)