aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorMasanori Kakura <kakurasan@gmail.com>2020-10-05 21:24:24 +0900
committerJan <sentrycraft123@gmail.com>2020-10-05 17:12:38 +0200
commita65cd5add177b4a883b308dc3b9504e93abeeca7 (patch)
treea3a476409a303464166c756af233171614cbf9d2 /src/meson.build
parentd07122673c9c66b41cf311ff4c9d1abed49fc669 (diff)
downloadpolecat-a65cd5add177b4a883b308dc3b9504e93abeeca7.tar.gz
polecat-a65cd5add177b4a883b308dc3b9504e93abeeca7.zip
Use Meson build system
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
new file mode 100644
index 0000000..06aae89
--- /dev/null
+++ b/src/meson.build
@@ -0,0 +1,28 @@
+polecat_deps = [libarchive_dep, libcurl_dep, libjson_c_dep]
+
+polecat_sources = files(
+ 'common.c',
+ 'common.h',
+ 'config.c',
+ 'config.h',
+ 'dxvk.c',
+ 'dxvk.h',
+ 'lutris.c',
+ 'lutris.h',
+ 'main.c',
+ 'main.h',
+ 'net.c',
+ 'net.h',
+ 'tar.c',
+ 'tar.h',
+ 'wine.c',
+ 'wine.h',
+)
+
+executable(
+ 'polecat',
+ polecat_sources,
+ dependencies : polecat_deps,
+ include_directories : conf_inc,
+ install : true,
+)