aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2020-10-20 20:14:41 +0200
committerJan200101 <sentrycraft123@gmail.com>2020-10-20 20:14:41 +0200
commitdb8ae62fb64fa33657f598a62045f17fc779ef8b (patch)
tree26de2baf2506c6acd072770d220b77ecb3aed60c /CMakeLists.txt
parenta8038e640523a65ac347be9f674348ecc11ce356 (diff)
downloadpolecat-db8ae62fb64fa33657f598a62045f17fc779ef8b.tar.gz
polecat-db8ae62fb64fa33657f598a62045f17fc779ef8b.zip
properly include header directories, change how json-c is found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 750c419..b81d1ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,11 @@ if("${CMAKE_BUILD_TYPE}" STREQUAL "Debug")
endif()
add_executable(${CMAKE_PROJECT_NAME} ${SOURCES})
+
target_link_libraries(${CMAKE_PROJECT_NAME} LINK_PUBLIC ${LIBCURL_LIBRARIES})
target_link_libraries(${CMAKE_PROJECT_NAME} LINK_PUBLIC ${JSONC_LIBRARIES})
-target_link_libraries(${CMAKE_PROJECT_NAME} LINK_PUBLIC ${LIBARCHIVE_LIBRARIES}) \ No newline at end of file
+target_link_libraries(${CMAKE_PROJECT_NAME} LINK_PUBLIC ${LIBARCHIVE_LIBRARIES})
+
+target_include_directories(${CMAKE_PROJECT_NAME} PUBLIC ${LIBCURL_INCLUDE_DIRS})
+target_include_directories(${CMAKE_PROJECT_NAME} PUBLIC ${JSONC_INCLUDE_DIRS})
+target_include_directories(${CMAKE_PROJECT_NAME} PUBLIC ${LIBARCHIVE_INCLUDE_DIRS}) \ No newline at end of file