aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2023-06-20 12:58:47 +0200
committerJan200101 <sentrycraft123@gmail.com>2023-06-20 12:58:47 +0200
commit406b505a07c39095abc8c0c1dcfd989712930f7d (patch)
tree0a04aa58c852a08e765094c8ae3ebe8b287e6085 /meson.build
parentdade9f4849438cf1a62db6ac273934872083c233 (diff)
downloadlite-xl-plugin-manager-406b505a07c39095abc8c0c1dcfd989712930f7d.tar.gz
lite-xl-plugin-manager-406b505a07c39095abc8c0c1dcfd989712930f7d.zip
Set variable name with xxd instead of relying on path
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 9 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index b4a8a04..b72e486 100644
--- a/meson.build
+++ b/meson.build
@@ -34,7 +34,7 @@ if not microtar_dep.found()
endif
lpm_source = files('src/lpm.c')
-cargs = []
+cflags = []
if get_option('static')
lua_exe = find_program('lua')
xxd_exe = find_program('xxd')
@@ -48,11 +48,17 @@ if get_option('static')
lpm_source += configure_file(
capture: true,
- command: [xxd_exe, '-i', '@INPUT@'],
+ command: [xxd_exe, '-n', 'lpm_luac', '-i', '@INPUT@'],
input: lpm_luac,
output: 'lpm.lua.c'
)
+ cflags += '-DLPM_STATIC'
+
endif
-executable('lpm', lpm_source, dependencies: [zlib_dep, mbedtls_dep, libgit2_dep, libzip_dep, lua_dep, microtar_dep]) \ No newline at end of file
+executable('lpm',
+ lpm_source,
+ dependencies: [zlib_dep, mbedtls_dep, libgit2_dep, libzip_dep, lua_dep, microtar_dep],
+ c_args: cflags
+) \ No newline at end of file