aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam <adamdharrison@gmail.com>2023-06-20 09:14:26 -0400
committerGitHub <noreply@github.com>2023-06-20 09:14:26 -0400
commit149960eac5348ae46b5b56643d50cf69d9ac8a1c (patch)
tree64dad26552fe39c90c94b79b9b3c1fd95d42f1e7 /meson.build
parente655a6add9af02a0b40e065fc62127b92b2638f1 (diff)
downloadlite-xl-plugin-manager-revert-25-PR/xxd_set_name.tar.gz
lite-xl-plugin-manager-revert-25-PR/xxd_set_name.zip
Revert "Set variable name with xxd instead of relying on path"revert-25-PR/xxd_set_name
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 3 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index b72e486..b4a8a04 100644
--- a/meson.build
+++ b/meson.build
@@ -34,7 +34,7 @@ if not microtar_dep.found()
endif
lpm_source = files('src/lpm.c')
-cflags = []
+cargs = []
if get_option('static')
lua_exe = find_program('lua')
xxd_exe = find_program('xxd')
@@ -48,17 +48,11 @@ if get_option('static')
lpm_source += configure_file(
capture: true,
- command: [xxd_exe, '-n', 'lpm_luac', '-i', '@INPUT@'],
+ command: [xxd_exe, '-i', '@INPUT@'],
input: lpm_luac,
output: 'lpm.lua.c'
)
- cflags += '-DLPM_STATIC'
-
endif
-executable('lpm',
- lpm_source,
- dependencies: [zlib_dep, mbedtls_dep, libgit2_dep, libzip_dep, lua_dep, microtar_dep],
- c_args: cflags
-) \ No newline at end of file
+executable('lpm', lpm_source, dependencies: [zlib_dep, mbedtls_dep, libgit2_dep, libzip_dep, lua_dep, microtar_dep]) \ No newline at end of file