aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuldoman <giulio.lettieri@gmail.com>2024-05-12 22:35:45 +0200
committerGuldoman <giulio.lettieri@gmail.com>2024-05-12 22:35:45 +0200
commit81f1703a7ad3603d7b983680098ed17dbbbace53 (patch)
treedf18e51cc328177e01c3c7fc31dcf10186b0d3d3 /meson.build
parent7f5933f02ab229cabb1ad2bb1a900ef2a9165ed3 (diff)
downloadlite-xl-plugin-manager-81f1703a7ad3603d7b983680098ed17dbbbace53.tar.gz
lite-xl-plugin-manager-81f1703a7ad3603d7b983680098ed17dbbbace53.zip
Fix meson static lua source generation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a25d1eb..2dc4ea1 100644
--- a/meson.build
+++ b/meson.build
@@ -50,7 +50,7 @@ if get_option('static')
lpm_source += configure_file(
capture: false,
- command: [lua_exe, '-e', 'f = string.dump(assert(load(io.lines("@INPUT@","L"), "=lpm.lua")) io.open("@OUTPUT0@", "wb"):write("unsigned char lpm_luac[] = \"" .. f:gsub(".", function (c) return string.format("\\\x%02X",string.byte(c)) end) .. "\";unsigned int lpm_luac_len = " .. #f .. ";")'],
+ command: [lua_exe, '-e', 'f = string.dump(assert(load(io.lines("@INPUT0@", "L"), "=lpm.lua"))) io.open("@OUTPUT0@", "wb"):write("unsigned char lpm_luac[] = \"" .. f:gsub(".", function (c) return string.format("\\\x%02X",string.byte(c)) end) .. "\";unsigned int lpm_luac_len = " .. #f .. ";")'],
input: files('src/lpm.lua'),
output: 'lpm.lua.c'
)