aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Harrison <adamdharrison@gmail.com>2024-05-12 16:24:32 -0400
committerAdam Harrison <adamdharrison@gmail.com>2024-05-12 16:24:32 -0400
commit7f5933f02ab229cabb1ad2bb1a900ef2a9165ed3 (patch)
treec570a5abbdc5755d4c2072903b98ace37ebff5a7 /meson.build
parentc21bbc8129b55f95723110ac837179dec479459c (diff)
downloadlite-xl-plugin-manager-7f5933f02ab229cabb1ad2bb1a900ef2a9165ed3.tar.gz
lite-xl-plugin-manager-7f5933f02ab229cabb1ad2bb1a900ef2a9165ed3.zip
Updated meson and build.sh to remove source context for LPM_STATIC builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e6e294e..a25d1eb 100644
--- a/meson.build
+++ b/meson.build
@@ -50,7 +50,7 @@ if get_option('static')
lpm_source += configure_file(
capture: false,
- command: [lua_exe, '-e', 'f = string.dump(assert(loadfile("@INPUT0@"))) io.open("@OUTPUT0@", "wb"):write("unsigned char lpm_luac[] = \"" .. f:gsub(".", function (c) return string.format("\\\x%02X",string.byte(c)) end) .. "\";unsigned int lpm_luac_len = " .. #f .. ";")'],
+ command: [lua_exe, '-e', 'f = string.dump(assert(load(io.lines("@INPUT@","L"), "=lpm.lua")) io.open("@OUTPUT0@", "wb"):write("unsigned char lpm_luac[] = \"" .. f:gsub(".", function (c) return string.format("\\\x%02X",string.byte(c)) end) .. "\";unsigned int lpm_luac_len = " .. #f .. ";")'],
input: files('src/lpm.lua'),
output: 'lpm.lua.c'
)