aboutsummaryrefslogtreecommitdiff
path: root/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Harrison <adamdharrison@gmail.com>2023-07-06 06:37:41 -0400
committerAdam Harrison <adamdharrison@gmail.com>2023-07-06 06:37:41 -0400
commit9db10386430479067795bec66bb26343ff176ded (patch)
tree5ad0cf95abde7cf03afaf8f70af8549d46b09a46 /lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
parent57092d80cb07fa1a84873769fa92165426196054 (diff)
downloadlite-xl-plugin-manager-9db10386430479067795bec66bb26343ff176ded.tar.gz
lite-xl-plugin-manager-9db10386430479067795bec66bb26343ff176ded.zip
Removed old mbedtls, replacing with submodule.
Diffstat (limited to 'lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt')
-rw-r--r--lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt b/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
deleted file mode 100644
index 29cbeb8..0000000
--- a/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
+++ /dev/null
@@ -1,30 +0,0 @@
-set(libs
- ${mbedx509_target}
-)
-
-if(USE_PKCS11_HELPER_LIBRARY)
- set(libs ${libs} pkcs11-helper)
-endif(USE_PKCS11_HELPER_LIBRARY)
-
-if(ENABLE_ZLIB_SUPPORT)
- set(libs ${libs} ${ZLIB_LIBRARIES})
-endif(ENABLE_ZLIB_SUPPORT)
-
-set(executables
- cert_app
- cert_req
- cert_write
- crl_app
- req_app
-)
-
-foreach(exe IN LISTS executables)
- add_executable(${exe} ${exe}.c $<TARGET_OBJECTS:mbedtls_test>)
- target_link_libraries(${exe} ${libs})
-endforeach()
-
-target_link_libraries(cert_app ${mbedtls_target})
-
-install(TARGETS ${executables}
- DESTINATION "bin"
- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)