aboutsummaryrefslogtreecommitdiff
path: root/lib/mbedtls-2.27.0/programs/util/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Harrison <adamdharrison@gmail.com>2022-11-26 16:20:59 -0500
committerAdam Harrison <adamdharrison@gmail.com>2022-11-29 18:39:46 -0500
commitfc0c4ed9a3103e0e6534311923668879fc8e0875 (patch)
tree6e7723c3f45d39f06c243d9c18a3c038da948793 /lib/mbedtls-2.27.0/programs/util/CMakeLists.txt
parent3836606e2b735ba7b2dc0f580231843660587fb4 (diff)
downloadlite-xl-plugin-manager-fc0c4ed9a3103e0e6534311923668879fc8e0875.tar.gz
lite-xl-plugin-manager-fc0c4ed9a3103e0e6534311923668879fc8e0875.zip
Removed openssl, and curl, and added mbedded tls.curl-removal
Almost fully removed curl, needs more testing. Fixed most issues, now trying to cross compile. Fix? Sigh.
Diffstat (limited to 'lib/mbedtls-2.27.0/programs/util/CMakeLists.txt')
-rw-r--r--lib/mbedtls-2.27.0/programs/util/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/mbedtls-2.27.0/programs/util/CMakeLists.txt b/lib/mbedtls-2.27.0/programs/util/CMakeLists.txt
new file mode 100644
index 0000000..2a11212
--- /dev/null
+++ b/lib/mbedtls-2.27.0/programs/util/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(libs
+ ${mbedcrypto_target}
+)
+
+set(executables
+ pem2der
+ strerror
+)
+
+foreach(exe IN LISTS executables)
+ add_executable(${exe} ${exe}.c $<TARGET_OBJECTS:mbedtls_test>)
+ target_link_libraries(${exe} ${libs})
+endforeach()
+
+install(TARGETS ${executables}
+ DESTINATION "bin"
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)