summaryrefslogtreecommitdiff
path: root/SPECS/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'SPECS/kernel.spec')
-rwxr-xr-xSPECS/kernel.spec31
1 files changed, 18 insertions, 13 deletions
diff --git a/SPECS/kernel.spec b/SPECS/kernel.spec
index 202fd71..1a63f5a 100755
--- a/SPECS/kernel.spec
+++ b/SPECS/kernel.spec
@@ -130,15 +130,15 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.17
-%define rpmversion 5.17.9
+%define rpmversion 5.17.11
%define patchversion 5.17
-%define pkgrelease 302
+%define pkgrelease 301
# This is needed to do merge window version magic
%define patchlevel 17
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 302%{?buildid}%{?dist}
+%define specrelease 301%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -695,7 +695,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.17.9.tar.xz
+Source0: linux-5.17.11.tar.xz
Source1: Makefile.rhelver
@@ -869,8 +869,6 @@ Patch300: linux-surface.patch
Patch301: steam-deck.patch
# temporary patches
-# https://gitlab.com/cki-project/kernel-ark/-/merge_requests/1788
-Patch501: simpledrm-nvidia.patch
# https://gitlab.freedesktop.org/drm/amd/-/issues/1925
Patch502: 0001-drm-amd-pm-correct-the-metrics-version-for-SMU-11.0..patch
%endif
@@ -1403,8 +1401,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.17.9 -c
-mv linux-5.17.9 linux-%{KVERREL}
+%setup -q -n kernel-5.17.11 -c
+mv linux-5.17.11 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@@ -1424,7 +1422,7 @@ ApplyOptionalPatch linux-surface.patch
ApplyOptionalPatch steam-deck.patch
# temporary patches
-ApplyOptionalPatch simpledrm-nvidia.patch
+ApplyOptionalPatch 0001-drm-amd-pm-correct-the-metrics-version-for-SMU-11.0..patch
%endif
ApplyOptionalPatch linux-kernel-test.patch
@@ -3044,11 +3042,18 @@ fi
#
#
%changelog
-* Mon May 23 2022 Jan Drögehoff <sentrycraft123@gmail.com> - 5.17.9-302.fsync
-- Add patch
+* Sun May 29 2022 Jan Drögehoff <sentrycraft123@gmail.com> - 5.17.11-301.fsync
+- Linux v5.17.11 futex2 zen openrgb
-* Sat May 21 2022 Jan Drögehoff <sentrycraft123@gmail.com> - 5.17.9-301.fsync
-- Linux v5.17.9 futex2 zen openrgb
+* Wed May 25 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.17.11-0]
+- Linux v5.17.11 (Justin M. Forbes)
+
+* Wed May 25 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.17.11-0]
+- Linux v5.17.11
+
+* Wed May 25 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.17.10-0]
+- fedora: Re-enable efifb and vesafb drivers (Javier Martinez Canillas)
+- drivers/firmware: skip simpledrm if nvidia-drm.modeset=1 is set (Javier Martinez Canillas)
* Wed May 18 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.17.9-0]
- Fix changelog for 5.17.8 (Justin M. Forbes)