summaryrefslogtreecommitdiff
path: root/SPECS/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'SPECS/kernel.spec')
-rw-r--r--SPECS/kernel.spec46
1 files changed, 21 insertions, 25 deletions
diff --git a/SPECS/kernel.spec b/SPECS/kernel.spec
index 60692d4..78baf84 100644
--- a/SPECS/kernel.spec
+++ b/SPECS/kernel.spec
@@ -82,19 +82,19 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 202
+%global baserelease 201
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
# which yields a base_sublevel of 0.
-%define base_sublevel 9
+%define base_sublevel 10
## If this is a released kernel ##
%if 0%{?released_kernel}
# Do we have a -stable update to apply?
-%define stable_update 16
+%define stable_update 6
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
@@ -835,30 +835,24 @@ Patch68: 0001-drm-sun4i-sun6i_mipi_dsi-fix-horizontal-timing-calcu.patch
Patch70: 0001-e1000e-bump-up-timeout-to-wait-when-ME-un-configure-.patch
Patch72: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
-# https://patchwork.kernel.org/patch/11743769/
-Patch100: mmc-sdhci-iproc-Enable-eMMC-DDR-3.3V-support-for-bcm2711.patch
-
-# https://patchwork.kernel.org/patch/11745283/
-Patch101: brcmfmac-BCM4329-Fixes-and-improvement.patch
-
# https://patchwork.kernel.org/patch/11796255/
-Patch102: arm64-dts-rockchip-disable-USB-type-c-DisplayPort.patch
+Patch100: arm64-dts-rockchip-disable-USB-type-c-DisplayPort.patch
# Tegra fixes
-Patch105: 0001-PCI-Add-MCFG-quirks-for-Tegra194-host-controllers.patch
-Patch106: arm64-tegra-Use-valid-PWM-period-for-VDD_GPU-on-Tegra210.patch
-# https://www.spinics.net/lists/linux-tegra/msg53605.html
-Patch108: iommu-tegra-smmu-Fix-TLB-line-for-Tegra210.patch
+Patch101: 0001-PCI-Add-MCFG-quirks-for-Tegra194-host-controllers.patch
# A patch to fix some undocumented things broke a bunch of Allwinner networks due to wrong assumptions
-Patch124: 0001-update-phy-on-pine64-a64-devices.patch
-# https://patchwork.kernel.org/project/linux-arm-kernel/patch/20201025140144.28693-1-ats@offog.org/
-Patch126: ARM-dts-sun7i-pcduino3-nano-enable-RGMII-RX-TX-delay-on-PHY.patch
+Patch102: 0001-update-phy-on-pine64-a64-devices.patch
+
+# OMAP Pandaboard fix
+Patch103: arm-pandaboard-fix-add-bluetooth.patch
+
+Patch105: 0001-ALSA-hda-via-Fix-runtime-PM-for-Clevo-W35xSS.patch
-# rhbz 1897038
-Patch132: bluetooth-fix-LL-privacy-BLE-device-fails-to-connect.patch
+# Nouveau mDP detection fix
+Patch107: 0001-drm-nouveau-kms-handle-mDP-connectors.patch
-# Linux-tkg patches - https://github.com/Frogging-Family/linux-tkg/tree/master/linux-tkg-patches/5.8
+# linux-fsync patches
Patch200: zen.patch
Patch201: futex2.patch
@@ -1554,7 +1548,7 @@ pathfix.py -i "%{__python3} %{py3_shbang_opts}" -p -n \
tools/perf/scripts/python/stat-cpi.py \
tools/perf/scripts/python/sched-migration.py \
Documentation \
- scripts/gen_compile_commands.py
+ scripts/clang-tools
# only deal with configs if we are going to build for the arch
%ifnarch %nobuildarches
@@ -2975,11 +2969,13 @@ fi
#
#
%changelog
-* Sun Jan 3 03:24:01 CET 2021 Jan Drögehoff <sentrycraft123@gmail.com> - 5.9.16-202.fsync
-- force futex2
+* Thu Jan 14 21:14:08 CET 2021 Jan Drögehoff <sentrycraft123@gmail.com> - 5.10.6-201.fsync
+- Linux v5.10.6 futex2 zen
-* Sun Dec 27 22:03:29 CET 2020 Jan Drögehoff <sentrycraft123@gmail.com> - 5.9.16-201.fsync
-- Linux v5.9.16 futex2 zen
+* Mon Jan 11 06:51:13 CST 2021 Justin M. Forbes <jforbes@fedoraproject.org> - 5.10.6-200
+- Linux v5.10.6 rebase
+- Fix bluetooth controller initialization (rhbz 1898495)
+- Fix CVE-2020-36158 (rhbz 1913348 1913349)
* Mon Dec 21 07:41:08 CST 2020 Justin M. Forbes <jforbes@fedoraproject.org> - 5.9.16-200
- Linux v5.9.16