summaryrefslogtreecommitdiff
path: root/SPECS/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'SPECS/kernel.spec')
-rw-r--r--SPECS/kernel.spec20
1 files changed, 15 insertions, 5 deletions
diff --git a/SPECS/kernel.spec b/SPECS/kernel.spec
index 12e62b1..832018d 100644
--- a/SPECS/kernel.spec
+++ b/SPECS/kernel.spec
@@ -54,6 +54,8 @@ Summary: The Linux kernel
%if %{zipmodules}
%global zipsed -e 's/\.ko$/\.ko.xz/'
+# for parallel xz processes, replace with 1 to go back to single process
+%global zcpu `nproc --all`
%endif
%define buildid .fsync
@@ -92,7 +94,7 @@ Summary: The Linux kernel
%if 0%{?released_kernel}
# Do we have a -stable update to apply?
-%define stable_update 9
+%define stable_update 10
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
@@ -204,7 +206,7 @@ Summary: The Linux kernel
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
-%define with_headers 1
+%define with_headers 0
%define with_cross_headers 0
# no selftests for now
%define with_selftests 0
@@ -868,6 +870,9 @@ Patch131: arm64-dts-allwinner-h6-Pine-H64-Fix-ethernet-node.patch
# rhbz 1897038
Patch132: bluetooth-fix-LL-privacy-BLE-device-fails-to-connect.patch
+# CVE-2020-28941 rhbz 1899985 1899986
+Patch133: speakup-do-not-let-the-line-discipline-be-used-several-times.patch
+
# Linux-tkg patches - https://github.com/Frogging-Family/linux-tkg/tree/master/linux-tkg-patches/5.8
Patch200: zen.patch
Patch201: fsync.patch
@@ -2350,7 +2355,7 @@ find Documentation -type d | xargs chmod u+w
fi \
fi \
if [ "%{zipmodules}" -eq "1" ]; then \
- find $RPM_BUILD_ROOT/lib/modules/ -type f -name '*.ko' | %{SOURCE79} %{?_smp_mflags}; \
+ find $RPM_BUILD_ROOT/lib/modules/ -type f -name '*.ko' | xargs -P%{zcpu} xz; \
fi \
%{nil}
@@ -2985,8 +2990,13 @@ fi
#
#
%changelog
-* Mon Nov 23 20:49:48 CET 2020 Jan Drögehoff <sentrycraft123@gmail.com> - 5.9.9-201.fsync
-- Linux v5.9.9 fsync zen
+* Wed Nov 25 19:20:00 CET 2020 Jan Drögehoff <sentrycraft123@gmail.com> - 5.9.10-201.fsync
+- Linux v5.9.10 fsync zen
+
+* Mon Nov 23 09:58:15 CST 2020 Justin M. Forbes <jforbes@fedoraproject.org> - 5.9.10-200
+- Linux v5.9.10
+- Fix CVE-2020-28941 (rhbz 1899985 1899986)
+- Fix CVE-2020-4788 (rhbz 1888433 1900437)
* Thu Nov 19 07:09:26 CST 2020 Justin M. Forbes <jforbes@fedoraproject.org> - 5.9.9-200
- Linux v5.9.9