aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..44ae5d4
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,18 @@
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+find_package(spdlog REQUIRED)
+
+plugin_manifest(SouthRPC name "South-RPC")
+plugin_manifest(SouthRPC displayname "South RPC")
+plugin_manifest(SouthRPC description "Implements JSON-RPC Bridge for Northstar over TCP/IP")
+plugin_manifest(SouthRPC run_on_server OFF)
+plugin_manifest(SouthRPC run_on_client ON)
+
+add_library(SouthRPC SHARED
+ ${CMAKE_CURRENT_SOURCE_DIR}/init.cpp
+)
+
+target_precompile_headers(SouthRPC PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/plugin.h)
+
+plugin_link(SouthRPC)