aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f3113e0..80a59bb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,8 +6,7 @@ add_subdirectory(vdf)
add_subdirectory(threading)
set(CFLAGS
- -Wall -Wextra -pedantic
- -Wfloat-equal -Wundef
+ -Wall -Wextra -pedantic -Wfloat-equal
-Wstrict-overflow=5 -Wunreachable-code
-Wcast-qual -Wswitch-default
-Wconversion -Wshadow -Wstrict-aliasing