aboutsummaryrefslogtreecommitdiff
path: root/src/cli/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-06-29 19:03:40 +0200
committerJan200101 <sentrycraft123@gmail.com>2022-06-29 19:03:40 +0200
commitf8a584aef10a252460f2cd161826f44afdc3324b (patch)
treea0cc6ebbcffcc0632b118d01a5875bd1f40f200a /src/cli/CMakeLists.txt
parentd0b5c9238acc63ec6def1fd16c47f06f8c682f2e (diff)
downloadOFQT-f8a584aef10a252460f2cd161826f44afdc3324b.tar.gz
OFQT-f8a584aef10a252460f2cd161826f44afdc3324b.zip
add source sdk path fetching, directly launch OF via sdk executable
- guard Flatpak logic for non Linux UNIX systems - add /proc check on FreeBSD - allow arguments when launching OF - update README - add alternative launch options to CMakeLists.txt - add CFLAGS to all libraries and executables
Diffstat (limited to 'src/cli/CMakeLists.txt')
-rw-r--r--src/cli/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/cli/CMakeLists.txt b/src/cli/CMakeLists.txt
index 38e5e13..2947a5b 100644
--- a/src/cli/CMakeLists.txt
+++ b/src/cli/CMakeLists.txt
@@ -12,6 +12,7 @@ set(THREADS_PREFER_PTHREAD_FLAG ON)
find_package(Threads REQUIRED)
add_executable(${FRONTEND_NAME} ${CLI_SOURCES})
+target_compile_options(${FRONTEND_NAME} PUBLIC ${CFLAGS})
target_link_libraries(${FRONTEND_NAME} PRIVATE tvn)
target_link_libraries(${FRONTEND_NAME} PRIVATE Threads::Threads)
install(TARGETS ${FRONTEND_NAME})