aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-06-29 19:03:40 +0200
committerJan200101 <sentrycraft123@gmail.com>2022-06-29 19:03:40 +0200
commitf8a584aef10a252460f2cd161826f44afdc3324b (patch)
treea0cc6ebbcffcc0632b118d01a5875bd1f40f200a /CMakeLists.txt
parentd0b5c9238acc63ec6def1fd16c47f06f8c682f2e (diff)
downloadOFQT-f8a584aef10a252460f2cd161826f44afdc3324b.tar.gz
OFQT-f8a584aef10a252460f2cd161826f44afdc3324b.zip
add source sdk path fetching, directly launch OF via sdk executable
- guard Flatpak logic for non Linux UNIX systems - add /proc check on FreeBSD - allow arguments when launching OF - update README - add alternative launch options to CMakeLists.txt - add CFLAGS to all libraries and executables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 139784b..82eaa1d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,16 +14,29 @@ project(OFQT VERSION 0.1.3 LANGUAGES C)
option(BUILD_CLI "Build the CLI client" OFF)
option(BUILD_QT "Build the Qt GUI client" OFF)
option(ENABLE_TESTS "Enable tests of the various components" OFF)
+option(DIRECT_LAUNCH "Launch OpenFortress directly instead of via Steam" ON)
+option(NAIVE_LAUNCH "Launch through the Steam Browser Protocol [Does not support Launch Options]" OFF)
if (ENABLE_TESTS)
enable_testing()
endif()
+
set(TOAST_DEFAULT_REMOTE "http://toast.openfortress.fun/toast" CACHE STRING
"Default Mirror to get OpenFortress files from")
add_compile_definitions(NAME="${CMAKE_PROJECT_NAME}")
add_compile_definitions(VERSION="${CMAKE_PROJECT_VERSION}")
+if(DIRECT_LAUNCH)
+ message(STATUS "Launch type: Direct")
+ add_compile_definitions("STEAM_DIRECT_LAUNCH")
+elseif(NAIVE_LAUNCH)
+ message(STATUS "Launch type: Steam Naive")
+ add_compile_definitions("STEAM_NAIVE_LAUNCH")
+else()
+ message(STATUS "Launch type: Steam")
+endif()
+
add_compile_definitions(TOAST_DEFAULT_REMOTE="${TOAST_DEFAULT_REMOTE}")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")