aboutsummaryrefslogtreecommitdiff
path: root/src/cli/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/cli/CMakeLists.txt')
-rw-r--r--src/cli/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/cli/CMakeLists.txt b/src/cli/CMakeLists.txt
new file mode 100644
index 0000000..fc46a42
--- /dev/null
+++ b/src/cli/CMakeLists.txt
@@ -0,0 +1,12 @@
+SET(FRONTEND_NAME "OFCL")
+
+SET(CLI_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/commands.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/commands.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/main.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/updater.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/updater.h
+)
+
+add_executable(${FRONTEND_NAME} ${CLI_SOURCES})
+target_link_libraries(${FRONTEND_NAME} PRIVATE libofqt)