aboutsummaryrefslogtreecommitdiff
path: root/src/vdf/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-06-26 21:39:17 +0200
committerJan200101 <sentrycraft123@gmail.com>2022-06-26 21:39:17 +0200
commita93baa212f3c7b57a08cb9084d38994290195d78 (patch)
treeebac4c1bc761d870b406704c13e0003c9e88536f /src/vdf/CMakeLists.txt
parent800a34d15fc37572709bdda32e5c7428dedd9085 (diff)
downloadOFQT-a93baa212f3c7b57a08cb9084d38994290195d78.tar.gz
OFQT-a93baa212f3c7b57a08cb9084d38994290195d78.zip
add vdf library
Diffstat (limited to 'src/vdf/CMakeLists.txt')
-rw-r--r--src/vdf/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/vdf/CMakeLists.txt b/src/vdf/CMakeLists.txt
new file mode 100644
index 0000000..a3a4387
--- /dev/null
+++ b/src/vdf/CMakeLists.txt
@@ -0,0 +1,11 @@
+
+list(APPEND
+ VDF_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/vdf.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/vdf.c
+)
+
+add_library(vdf STATIC ${VDF_SOURCES})
+target_compile_options(vdf PUBLIC ${CFLAGS})
+
+target_include_directories(vdf PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})