aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-06-26 21:39:17 +0200
committerJan200101 <sentrycraft123@gmail.com>2022-06-26 21:39:17 +0200
commita93baa212f3c7b57a08cb9084d38994290195d78 (patch)
treeebac4c1bc761d870b406704c13e0003c9e88536f /src/CMakeLists.txt
parent800a34d15fc37572709bdda32e5c7428dedd9085 (diff)
downloadOFQT-a93baa212f3c7b57a08cb9084d38994290195d78.tar.gz
OFQT-a93baa212f3c7b57a08cb9084d38994290195d78.zip
add vdf library
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c48af2d..1e11530 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -2,6 +2,7 @@
find_package(Libcurl REQUIRED)
find_package(JsonC REQUIRED)
add_subdirectory(hash)
+add_subdirectory(vdf)
set(CFLAGS
-Wall -Wextra -pedantic
@@ -34,6 +35,7 @@ target_include_directories(tvn PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
target_link_libraries(tvn LINK_PUBLIC ${LIBCURL_LIBRARIES})
target_link_libraries(tvn LINK_PUBLIC ${JSONC_LIBRARIES})
target_link_libraries(tvn LINK_PUBLIC md5)
+target_link_libraries(tvn LINK_PUBLIC vdf)
if(BUILD_CLI)
add_subdirectory(cli)