aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-06-16 22:43:56 +0200
committerJan200101 <sentrycraft123@gmail.com>2022-06-16 22:43:56 +0200
commit10bed2d13e6d670f4ed0f18e564f1e6790f2d812 (patch)
tree1f702032b39c6c854d6d8977b8d04d34e6e18f85 /src/CMakeLists.txt
parente249a716e8c2d53ea843cf66ffcee75f184c0b6d (diff)
downloadOFQT-10bed2d13e6d670f4ed0f18e564f1e6790f2d812.tar.gz
OFQT-10bed2d13e6d670f4ed0f18e564f1e6790f2d812.zip
Change MD5 function signatures, make libtvn static, not object
this solves a problem on x86_64 Windows where the MD5 functions were included within ntdll. STATIC libraries have better defined behavior than static ones, and we do not compile the same thing multiple times since we use it as a libary.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 05cbcb2..c48af2d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -25,7 +25,7 @@ list(APPEND
${CMAKE_CURRENT_SOURCE_DIR}/toast.h
)
-add_library(tvn OBJECT ${CORE_SOURCES})
+add_library(tvn STATIC ${CORE_SOURCES})
target_compile_options(tvn PUBLIC ${CFLAGS})
target_include_directories(tvn PUBLIC ${LIBCURL_INCLUDE_DIRS})