aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-06-28 17:44:01 +0200
committerJan200101 <sentrycraft123@gmail.com>2022-06-28 17:44:01 +0200
commita51036bf447a699511452da773dc4fad02192849 (patch)
tree116b9ec1d527e02db9023c836721bd046fe320ff /CMakeLists.txt
parenta93baa212f3c7b57a08cb9084d38994290195d78 (diff)
downloadOFQT-a51036bf447a699511452da773dc4fad02192849.tar.gz
OFQT-a51036bf447a699511452da773dc4fad02192849.zip
add unit tests for vdf & md5, allow escaped quotesvdf-parser
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dae6d50..139784b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,11 @@ project(OFQT VERSION 0.1.3 LANGUAGES C)
option(BUILD_CLI "Build the CLI client" OFF)
option(BUILD_QT "Build the Qt GUI client" OFF)
+option(ENABLE_TESTS "Enable tests of the various components" OFF)
+
+if (ENABLE_TESTS)
+ enable_testing()
+endif()
set(TOAST_DEFAULT_REMOTE "http://toast.openfortress.fun/toast" CACHE STRING
"Default Mirror to get OpenFortress files from")
@@ -21,8 +26,6 @@ add_compile_definitions(NAME="${CMAKE_PROJECT_NAME}")
add_compile_definitions(VERSION="${CMAKE_PROJECT_VERSION}")
add_compile_definitions(TOAST_DEFAULT_REMOTE="${TOAST_DEFAULT_REMOTE}")
-set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
-
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
add_subdirectory(src)