aboutsummaryrefslogtreecommitdiff
path: root/loader_wsock32_proxy/CMakeLists.txt
diff options
context:
space:
mode:
authorF1F7Y <64418963+F1F7Y@users.noreply.github.com>2023-06-30 03:10:24 +0200
committerGitHub <noreply@github.com>2023-06-29 21:10:24 -0400
commit71f0ee98ccc85d41ba7587d122c83011ab1e25c3 (patch)
treec362337bedb5d341c3f063e9a0b4840fb8b8ba2c /loader_wsock32_proxy/CMakeLists.txt
parentefd907105cf7906c78253631f75bf4fd83f769db (diff)
downloadNorthstarLauncher-71f0ee98ccc85d41ba7587d122c83011ab1e25c3.tar.gz
NorthstarLauncher-71f0ee98ccc85d41ba7587d122c83011ab1e25c3.zip
Reorganize third-party dependencies into `thirdparty` directory (#491)
* rename `include` to `thirdparty` * remove duplicate minhook in wsock32 * move minhook into its own directory * move openssl lib into separate directories
Diffstat (limited to 'loader_wsock32_proxy/CMakeLists.txt')
-rw-r--r--loader_wsock32_proxy/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/loader_wsock32_proxy/CMakeLists.txt b/loader_wsock32_proxy/CMakeLists.txt
index f663f342..81d0b04c 100644
--- a/loader_wsock32_proxy/CMakeLists.txt
+++ b/loader_wsock32_proxy/CMakeLists.txt
@@ -11,7 +11,7 @@ add_library(loader_wsock32_proxy SHARED
)
target_link_libraries(loader_wsock32_proxy PRIVATE
- ${CMAKE_CURRENT_SOURCE_DIR}/include/MinHook.x64.lib
+ ${CMAKE_SOURCE_DIR}/thirdparty/minhook/MinHook.x64.lib
mswsock.lib
ws2_32.lib
ShLwApi.lib
@@ -32,7 +32,7 @@ target_link_libraries(loader_wsock32_proxy PRIVATE
)
target_include_directories(loader_wsock32_proxy PRIVATE
- include
+ ${CMAKE_SOURCE_DIR}/thirdparty
)
target_precompile_headers(loader_wsock32_proxy PRIVATE pch.h)