aboutsummaryrefslogtreecommitdiff
path: root/NorthstarDLL/CMakeLists.txt
diff options
context:
space:
mode:
authorJack <66967891+ASpoonPlaysGames@users.noreply.github.com>2023-10-07 11:25:09 +0100
committerGitHub <noreply@github.com>2023-10-07 12:25:09 +0200
commitc093ee10f004f7e2b8be2b326a4b087392ded544 (patch)
tree14db03b2f10549fe368919157906cd6be32e60d3 /NorthstarDLL/CMakeLists.txt
parent9d8bedf580184313f419cdb60351e712712832e3 (diff)
downloadNorthstarLauncher-c093ee10f004f7e2b8be2b326a4b087392ded544.tar.gz
NorthstarLauncher-c093ee10f004f7e2b8be2b326a4b087392ded544.zip
Expose origin auth state and errors to squirrel (#468)
Also moves `NSIsMasterServerAuthenticated` out of `scriptserverbrowser.cpp` because it didn't really fit there This will be used for showing failed origin auth errors in the game's UI
Diffstat (limited to 'NorthstarDLL/CMakeLists.txt')
-rw-r--r--NorthstarDLL/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/NorthstarDLL/CMakeLists.txt b/NorthstarDLL/CMakeLists.txt
index a7ca1028..288d39b1 100644
--- a/NorthstarDLL/CMakeLists.txt
+++ b/NorthstarDLL/CMakeLists.txt
@@ -91,6 +91,7 @@ add_library(NorthstarDLL SHARED
"scripts/client/scriptbrowserhooks.cpp"
"scripts/client/scriptmainmenupromos.cpp"
"scripts/client/scriptmodmenu.cpp"
+ "scripts/client/scriptoriginauth.cpp"
"scripts/client/scriptserverbrowser.cpp"
"scripts/client/scriptservertoclientstringcommand.cpp"
"scripts/server/miscserverfixes.cpp"