aboutsummaryrefslogtreecommitdiff
path: root/NorthstarDLL/CMakeLists.txt
diff options
context:
space:
mode:
authorF1F7Y <64418963+F1F7Y@users.noreply.github.com>2023-06-30 03:10:24 +0200
committerGitHub <noreply@github.com>2023-06-29 21:10:24 -0400
commit71f0ee98ccc85d41ba7587d122c83011ab1e25c3 (patch)
treec362337bedb5d341c3f063e9a0b4840fb8b8ba2c /NorthstarDLL/CMakeLists.txt
parentefd907105cf7906c78253631f75bf4fd83f769db (diff)
downloadNorthstarLauncher-71f0ee98ccc85d41ba7587d122c83011ab1e25c3.tar.gz
NorthstarLauncher-71f0ee98ccc85d41ba7587d122c83011ab1e25c3.zip
Reorganize third-party dependencies into `thirdparty` directory (#491)
* rename `include` to `thirdparty` * remove duplicate minhook in wsock32 * move minhook into its own directory * move openssl lib into separate directories
Diffstat (limited to 'NorthstarDLL/CMakeLists.txt')
-rw-r--r--NorthstarDLL/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/NorthstarDLL/CMakeLists.txt b/NorthstarDLL/CMakeLists.txt
index 697cd8d8..11c4eb14 100644
--- a/NorthstarDLL/CMakeLists.txt
+++ b/NorthstarDLL/CMakeLists.txt
@@ -146,8 +146,8 @@ add_library(NorthstarDLL SHARED
)
target_link_libraries(NorthstarDLL PRIVATE
- ${CMAKE_SOURCE_DIR}/include/MinHook.x64.lib
- ${CMAKE_SOURCE_DIR}/include/libcurl/lib/libcurl_a.lib
+ ${CMAKE_SOURCE_DIR}/thirdparty/minhook/MinHook.x64.lib
+ ${CMAKE_SOURCE_DIR}/thirdparty/libcurl/lib/libcurl_a.lib
WS2_32.lib
Crypt32.lib
Cryptui.lib
@@ -160,7 +160,7 @@ target_link_libraries(NorthstarDLL PRIVATE
target_include_directories(NorthstarDLL PRIVATE
${CMAKE_SOURCE_DIR}/NorthstarDLL
- ${CMAKE_SOURCE_DIR}/include
+ ${CMAKE_SOURCE_DIR}/thirdparty
)
target_precompile_headers(NorthstarDLL PRIVATE pch.h)