aboutsummaryrefslogtreecommitdiff
path: root/NorthstarDLL/CMakeLists.txt
diff options
context:
space:
mode:
authorJan <sentrycraft123@gmail.com>2023-06-29 04:22:33 +0100
committerGitHub <noreply@github.com>2023-06-28 23:22:33 -0400
commitefd907105cf7906c78253631f75bf4fd83f769db (patch)
tree0516853204106852adb06ee1d69a74e8994309a0 /NorthstarDLL/CMakeLists.txt
parentb5c4e4e7ed81394070b05296ed087b6043d27667 (diff)
downloadNorthstarLauncher-efd907105cf7906c78253631f75bf4fd83f769db.tar.gz
NorthstarLauncher-efd907105cf7906c78253631f75bf4fd83f769db.zip
* turn implicit type casts into standard compliant explicit type casts * correct includes and library names * correct implicit use of std-namespaced functions * turn incomplete virtual implementations into pure virtuals (this also follows what the Source SDK tier0 header does) * define SqRecurseArgs ahead of implementation to fix templating problems * switch out removed getentity with getthisentity * fix calls to curl_easy_escape with wrong types * replace winapi-specific function with std starts_with function * format squirrel header
Diffstat (limited to 'NorthstarDLL/CMakeLists.txt')
-rw-r--r--NorthstarDLL/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/NorthstarDLL/CMakeLists.txt b/NorthstarDLL/CMakeLists.txt
index f9d61a2c..697cd8d8 100644
--- a/NorthstarDLL/CMakeLists.txt
+++ b/NorthstarDLL/CMakeLists.txt
@@ -148,7 +148,7 @@ add_library(NorthstarDLL SHARED
target_link_libraries(NorthstarDLL PRIVATE
${CMAKE_SOURCE_DIR}/include/MinHook.x64.lib
${CMAKE_SOURCE_DIR}/include/libcurl/lib/libcurl_a.lib
- Ws2_32.lib
+ WS2_32.lib
Crypt32.lib
Cryptui.lib
dbghelp.lib