aboutsummaryrefslogtreecommitdiff
path: root/NorthstarDLL/CMakeLists.txt
diff options
context:
space:
mode:
authorJan <sentrycraft123@gmail.com>2023-07-22 02:22:26 +0200
committerGitHub <noreply@github.com>2023-07-22 02:22:26 +0200
commitd3fb76f889101f024f410c194a66f0f4a2f6c4a0 (patch)
tree9739770458ee74e28474949b8e5e310c20f4734a /NorthstarDLL/CMakeLists.txt
parent9841d698f89e1ec6cc9b0c04df10bad6010a54fe (diff)
downloadNorthstarLauncher-d3fb76f889101f024f410c194a66f0f4a2f6c4a0.tar.gz
NorthstarLauncher-d3fb76f889101f024f410c194a66f0f4a2f6c4a0.zip
Replace vendored libcurl and minhook with submodules (#500)v1.17.1-rc1
* Replace vendored libcurl and minhook with submodules * Add cmake utility for checking submodules and initializing them * Update build instructions to use Git
Diffstat (limited to 'NorthstarDLL/CMakeLists.txt')
-rw-r--r--NorthstarDLL/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/NorthstarDLL/CMakeLists.txt b/NorthstarDLL/CMakeLists.txt
index 11c4eb14..f6ff8014 100644
--- a/NorthstarDLL/CMakeLists.txt
+++ b/NorthstarDLL/CMakeLists.txt
@@ -1,5 +1,8 @@
# NorthstarDLL
+find_package(minhook REQUIRED)
+find_package(libcurl REQUIRED)
+
add_library(NorthstarDLL SHARED
"client/audio.cpp"
"client/audio.h"
@@ -146,8 +149,8 @@ add_library(NorthstarDLL SHARED
)
target_link_libraries(NorthstarDLL PRIVATE
- ${CMAKE_SOURCE_DIR}/thirdparty/minhook/MinHook.x64.lib
- ${CMAKE_SOURCE_DIR}/thirdparty/libcurl/lib/libcurl_a.lib
+ minhook
+ libcurl
WS2_32.lib
Crypt32.lib
Cryptui.lib