aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJack <66967891+ASpoonPlaysGames@users.noreply.github.com>2023-12-28 14:51:45 +0000
committerGitHub <noreply@github.com>2023-12-28 14:51:45 +0000
commit3b63cf5c83b9f68952195e62e202dd557f7ca6af (patch)
treebd977e3f566a635ab4c734f2c12621614d44ce83 /CMakeLists.txt
parent0b507aa3eb55c2d06f314a46998cf9415f6a064a (diff)
parentf5ab6fb5e8be7b73e6003d4145081d5e0c0ce287 (diff)
downloadNorthstarLauncher-3b63cf5c83b9f68952195e62e202dd557f7ca6af.tar.gz
NorthstarLauncher-3b63cf5c83b9f68952195e62e202dd557f7ca6af.zip
Merge branch 'main' into cmake-format
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83c38a56..9bea0ce8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,10 +24,11 @@ set(NS_BINARY_DIR ${CMAKE_BINARY_DIR}/game)
message(STATUS "NS: Building to ${NS_BINARY_DIR}")
-list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/primedev/cmake")
include(utils)
+include_directories(primedev)
+include_directories(primedev/thirdparty)
+
# Targets
-add_subdirectory(loader_wsock32_proxy)
-add_subdirectory(NorthstarDLL)
-add_subdirectory(NorthstarLauncher)
+add_subdirectory(primedev)