aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeckoEidechse <40122905+GeckoEidechse@users.noreply.github.com>2024-11-12 17:11:31 +0100
committerGitHub <noreply@github.com>2024-11-12 17:11:31 +0100
commit6509283abd620038bf48f0d90ba23b8fa17feec7 (patch)
treea4186aef12d8c44e3bc71868f2e1556068e4a6dd /CMakeLists.txt
parenta4b09bc42d5f79ef86697c893efc9e3b7d966502 (diff)
parent13344f3910befa2cd15bfd306ba2c5e42e6c80ec (diff)
downloadNorthstarLauncher-6509283abd620038bf48f0d90ba23b8fa17feec7.tar.gz
NorthstarLauncher-6509283abd620038bf48f0d90ba23b8fa17feec7.zip
Merge branch 'main' into feat/overhaul-mod-loading-locationsfeat/overhaul-mod-loading-locations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9646ae1..c9516e52 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,3 +50,7 @@ include_directories(primedev/thirdparty)
# Targets
add_subdirectory(primedev)
+# Forces Minizip to not use functions that are not available in Win 7 libraries.
+if(WIN32)
+ target_compile_definitions(minizip PUBLIC -D_WIN32_WINNT=0x0601)
+endif()