aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml24
1 files changed, 12 insertions, 12 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index d2f1e87e..f1d26cf8 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "app"
-version = "2.1.0"
+version = "2.10.3"
description = "A Tauri App"
authors = ["you"]
license = ""
@@ -26,8 +26,8 @@ serde = { version = "1.0", features = ["derive"] }
tauri = { version = "1.4", features = ["api-all", "dialog", "updater"] }
tokio = { version = "1", features = ["full"] }
# Sentry (crash) logging
-sentry = "0.30"
-sentry-log = "0.30.0"
+sentry = "0.31"
+sentry-log = "0.31"
# Find steam games
steamlocate = "1.2"
# Error messages
@@ -37,9 +37,9 @@ libthermite = { version = "0.7.0-beta", features = ["proton"] }
# zip stuff
zip = "0.6.2"
# Regex
-regex = "1.6.0"
+regex = "1.9"
# Read out running application process names
-sysinfo = "0.26.2"
+sysinfo = "0.29.10"
# HTTP requests
reqwest = { version = "0.11", features = ["blocking"] }
# Persistent store for settings
@@ -47,20 +47,20 @@ tauri-plugin-store = { git = "https://github.com/tauri-apps/plugins-workspace",
# JSON5 parsing support (allows comments in JSON)
json5 = "0.4.1"
# Async recursion for recursive mod install
-async-recursion = "1.0.0"
+async-recursion = "1.0.5"
# For parsing timestamps
-chrono = "0.4.23"
+chrono = "0.4.31"
# TypeScript bindings
-ts-rs = "6.1"
+ts-rs = "7.0"
# const formatting
const_format = "0.2.30"
# Logging libraries
-pretty_env_logger = "0.4.0"
-log = "0.4.17"
+pretty_env_logger = "0.5.0"
+log = "0.4"
# Extracting zip files easily
zip-extract = "0.1.2"
# open urls
-open = "3.2.0"
+open = "5.0.0"
semver = "1.0"
# simplified filesystem access
glob = "0.3.1"
@@ -69,7 +69,7 @@ dirs = "5"
[target.'cfg(windows)'.dependencies]
# Windows API stuff
winapi = "0.3.9"
-winreg = "0.11.0"
+winreg = "0.51.0"
[features]
# by default Tauri runs in production mode