aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorJeremy Chone <jeremy.chone@gmail.com>2022-06-20 01:02:15 -0700
committerJeremy Chone <jeremy.chone@gmail.com>2022-06-20 01:02:15 -0700
commit051748771895bb040188221c3e4136878dbedb8a (patch)
tree9492d6020c9294b12b3fd912520746e0df847406 /src-tauri/Cargo.toml
downloadFlightCore-051748771895bb040188221c3e4136878dbedb8a.tar.gz
FlightCore-051748771895bb040188221c3e4136878dbedb8a.zip
. initial
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
new file mode 100644
index 00000000..afafa6e4
--- /dev/null
+++ b/src-tauri/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "app"
+version = "0.1.0"
+description = "A Tauri App"
+authors = ["you"]
+license = ""
+repository = ""
+default-run = "app"
+edition = "2021"
+rust-version = "1.57"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[build-dependencies]
+tauri-build = { version = "1.0.0", features = [] }
+
+[dependencies]
+serde_json = "1.0"
+serde = { version = "1.0", features = ["derive"] }
+tauri = { version = "1.0.0", features = ["api-all"] }
+
+[features]
+# by default Tauri runs in production mode
+# when `tauri dev` runs it is executed with `cargo run --no-default-features` if `devPath` is an URL
+default = [ "custom-protocol" ]
+# this feature is used used for production builds where `devPath` points to the filesystem
+# DO NOT remove this
+custom-protocol = [ "tauri/custom-protocol" ]