aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <40122905+GeckoEidechse@users.noreply.github.com>2023-05-01 03:06:10 +0200
committerGitHub <noreply@github.com>2023-05-01 03:06:10 +0200
commitd00c49812af54121867eb1835f9d25e44d16c109 (patch)
treea7eccc74159588fd5b3ca97867a75b0a594dc6a3 /src-tauri/Cargo.toml
parent06754cc2f63468a6a1945357918428fd9707cd91 (diff)
downloadFlightCore-d00c49812af54121867eb1835f9d25e44d16c109.tar.gz
FlightCore-d00c49812af54121867eb1835f9d25e44d16c109.zip
feat: Show error message if WebView2 not installed (#285)
* feat: Show error message if WebView2 not installed on Windows * fix: Add missing dependency * fix: Do not import lib on OS where not needed Don't need to import Windows lib on Linux * feat: Link to troubleshooting page directly * chore: Update comments * docs: Show error message in troubleshooting guide Show the "WebView2 not installed" error message in the troubleshooting guide * fix: Resolve clippy error * fix: Resolve clippy error (again)
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index 0f68a560..0f65d665 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -64,6 +64,8 @@ log = "0.4.17"
zip-extract = "0.1.2"
# open urls
open = "3.2.0"
+# Windows API stuff
+winapi = "0.3.9"
[features]
# by default Tauri runs in production mode