aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorJan <sentrycraft123@gmail.com>2023-07-18 14:26:20 +0200
committerGitHub <noreply@github.com>2023-07-18 14:26:20 +0200
commit9dccdb0b0335f82aa9f2e63642f16ff0f2699528 (patch)
tree22c4651dd5cafc4375e4cd2a76dccf5e389388c5 /src-tauri/Cargo.toml
parentdfa5af1746546d388a85081fae499c28521a20ea (diff)
downloadFlightCore-9dccdb0b0335f82aa9f2e63642f16ff0f2699528.tar.gz
FlightCore-9dccdb0b0335f82aa9f2e63642f16ff0f2699528.zip
feat: Add basic Proton management (#383)
Adds logic to install, remove, and check existing install of NorthstarProton.
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index ed523a4b..63ff51f7 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -33,7 +33,7 @@ steamlocate = "1.2"
# Error messages
anyhow = "1.0"
# libthermite for Northstar/mod install handling
-libthermite = "0.6.5"
+libthermite = { version = "0.6.5", features = ["proton"] }
# zip stuff
zip = "0.6.2"
# Regex
@@ -62,6 +62,8 @@ zip-extract = "0.1.2"
# open urls
open = "3.2.0"
semver = "1.0"
+# simplified filesystem access
+glob = "0.3.1"
dirs = "5"
[target.'cfg(windows)'.dependencies]