aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorJan <sentrycraft123@gmail.com>2023-04-06 15:06:38 +0200
committerGitHub <noreply@github.com>2023-04-06 15:06:38 +0200
commitdd1e870b279f990981dcbaff79c9db58fde18ba9 (patch)
tree72ac9445ee21d368d304aee0dcaa3bc8da32d03e /src-tauri/Cargo.toml
parentad19a08e24817c4e7256174c77316829f86bb0d3 (diff)
downloadFlightCore-dd1e870b279f990981dcbaff79c9db58fde18ba9.tar.gz
FlightCore-dd1e870b279f990981dcbaff79c9db58fde18ba9.zip
feat: Add ability to launch via Steam to DevView (#178)
* feat: Add ability to launch via Steam * document what get_titanfall_proton() does * revert explicit use of newly imported Path * Format source code to pass CI * Use new steamlocate compat_tool helper * cargo fmt * fix: Address various clippy issues Addresses clippy warnings caused by newly introduced code * fix: Cargo toml dependency formatting
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index c7d52d89..2267c239 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -29,7 +29,7 @@ tokio = { version = "1", features = ["full"] }
sentry = "0.30"
sentry-log = "0.30.0"
# Find steam games
-steamlocate = "1.0.2"
+steamlocate = "1.2"
# Error messages
anyhow = "1.0"
# libthermite for Northstar/mod install handling
@@ -61,6 +61,8 @@ pretty_env_logger = "0.4.0"
log = "0.4.17"
# Extracting zip files easily
zip-extract = "0.1.2"
+# open urls
+open = "3.2.0"
[features]
# by default Tauri runs in production mode