aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <40122905+GeckoEidechse@users.noreply.github.com>2022-11-13 15:29:29 +0100
committerGitHub <noreply@github.com>2022-11-13 15:29:29 +0100
commitfa25001d7f2a1962de8990f077f7f1601679a292 (patch)
tree95116620a6bff140826154a2bd39a965f1955d03 /src-tauri/Cargo.toml
parent8393a08f4cb937805d41bb9a0f7901fb5221746e (diff)
downloadFlightCore-fa25001d7f2a1962de8990f077f7f1601679a292.tar.gz
FlightCore-fa25001d7f2a1962de8990f077f7f1601679a292.zip
feat: Add JSON5 support, allows comments in JSON (#50)
Some mods have comments in their JSON. Northstar handles it fine, so we should too.
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index 4e0d2cba..ab2de8bf 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -38,6 +38,8 @@ sysinfo = "0.26.2"
reqwest = { version = "0.11", features = ["blocking"] }
# Persistent store for settings
tauri-plugin-store = { git = "https://github.com/tauri-apps/tauri-plugin-store", branch = "dev" }
+# JSON5 parsing support (allows comments in JSON)
+json5 = "0.4.1"
[features]
# by default Tauri runs in production mode