aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <40122905+GeckoEidechse@users.noreply.github.com>2023-02-05 15:53:34 +0100
committerGitHub <noreply@github.com>2023-02-05 15:53:34 +0100
commit802d7dfee77a3f58ee14a7ef6e2454e5aae62cbb (patch)
tree1c63107fafa7b535acd1a31a2e317e7535f85b62 /src-tauri/Cargo.toml
parent24cabc6019e702ac888a33311532a9832863b572 (diff)
downloadFlightCore-802d7dfee77a3f58ee14a7ef6e2454e5aae62cbb.tar.gz
FlightCore-802d7dfee77a3f58ee14a7ef6e2454e5aae62cbb.zip
feat: Auto-generate TS bindings (#140)
* feat: Initial trial to auto-generate TS bindings That way instead of manually duplicating code, we can just run `cargo test` to generate them. * fix: Update forgotten imports * refactor: Move FlightCoreVersion to autogen bind TypeScript binding autogenerated from Rust code * refactor: Move ReleaseInfo to autogen binding TypeScript binding autogenerated from Rust code * docs: Explain how to generate TS binds from Rust * feat: Check for binding changes in CI Checks for uncommitted binding changes in CI and fails if they differ * style: Formatting fixes
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index dcdf8d3b..dbd6f605 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -44,6 +44,8 @@ async-recursion = "1.0.0"
game-scanner = "1.1.4"
# For parsing timestamps
chrono = "0.4.23"
+# TypeScript bindings
+ts-rs = "6.1"
[features]
# by default Tauri runs in production mode