aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <40122905+GeckoEidechse@users.noreply.github.com>2023-03-21 09:31:36 +0100
committerGitHub <noreply@github.com>2023-03-21 08:31:36 +0000
commit36fdc302bef162d213d6a026c99614673b24a069 (patch)
treecadbdda49542ddf5234040206676a186ebe9b440 /src-tauri/Cargo.toml
parent25791906cc8c81368af5718f8ec6ee8b4f428b31 (diff)
downloadFlightCore-36fdc302bef162d213d6a026c99614673b24a069.tar.gz
FlightCore-36fdc302bef162d213d6a026c99614673b24a069.zip
feat: Proper logging (#223)
* feat: Initial setup of sentry logging * refactor: Replace some println with log call Not replacing all cause too large diff
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index 0e972064..2d803e7e 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -25,7 +25,9 @@ serde_json = "1.0"
serde = { version = "1.0", features = ["derive"] }
tauri = { version = "1.2", features = ["api-all", "updater"] }
tokio = { version = "1", features = ["full"] }
+# Sentry (crash) logging
sentry = "0.30"
+sentry-log = "0.30.0"
# Find steam games
steamlocate = "1.0.2"
# Error messages
@@ -54,6 +56,9 @@ chrono = "0.4.23"
ts-rs = "6.1"
# const formatting
const_format = "0.2.30"
+# Logging libraries
+pretty_env_logger = "0.4.0"
+log = "0.4.17"
# Extracting zip files easily
zip-extract = "0.1.2"