aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <gecko.eidechse+git@pm.me>2024-02-11 17:51:51 +0100
committerGeckoEidechse <gecko.eidechse+git@pm.me>2024-02-11 17:51:51 +0100
commit0f89bf6821ee1aacb2a47d5760f3edf078690571 (patch)
treeea09a89f4b6a21422c320270a507f997a8801713 /src-tauri/Cargo.toml
parent5284445cab89bb5af6d415c825a2cfa45cb92592 (diff)
parent205c3e3e6382de53e267ead750f2fe92cca06725 (diff)
downloadFlightCore-0f89bf6821ee1aacb2a47d5760f3edf078690571.tar.gz
FlightCore-0f89bf6821ee1aacb2a47d5760f3edf078690571.zip
Merge branch 'main' into refactor/pass-launch-options-object
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml12
1 files changed, 9 insertions, 3 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index 7934366b..9851b02a 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "flightcore"
-version = "2.17.3"
+version = "2.18.2"
description = "Mod-manager for Northstar"
authors = ["https://github.com/R2NorthstarTools/FlightCore/graphs/contributors"]
license = "MIT"
@@ -33,7 +33,7 @@ steamlocate = "1.2"
# Error messages
anyhow = "1.0"
# libthermite for Northstar/mod install handling
-libthermite = { version = "0.7.0", features = ["proton"] }
+libthermite = { version = "0.7.1", features = ["proton"] }
# zip stuff
zip = "0.6.2"
# Regex
@@ -58,7 +58,7 @@ const_format = "0.2.32"
pretty_env_logger = "0.5.0"
log = "0.4"
# Extracting zip files easily
-zip-extract = "0.1.2"
+zip-extract = "0.1.3"
# open urls
open = "5.0.1"
semver = "1.0"
@@ -66,6 +66,12 @@ semver = "1.0"
glob = "0.3.1"
dirs = "5"
+# Interacting with GitHub
+octocrab = "0.34.0"
+# Library for removing markdown links
+remove-markdown-links = "1.0.0"
+
+
[target.'cfg(windows)'.dependencies]
# Windows API stuff
winapi = "0.3.9"